[SURBL-Discuss] make test fail - SpamCopURI.pm line 117

Jeff Chan jeffc at surbl.org
Mon Apr 12 16:09:27 CEST 2004


On Monday, April 12, 2004, 3:02:46 PM, Jason Portwood wrote:
> I'm trying to install SpamCopURI and I've hit a snag on the make test

> Here's what I'm getting:

> PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
> -I/usr/libdata/perl/5.00503/mach -I/usr/libdata/perl/5.00503 -e 'use
> Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t
> t/bad...............syntax error at
> blib/lib/Mail/SpamAssassin/SpamCopURI.pm line 117, near "$f :"
> BEGIN failed--compilation aborted at t/bad.t line 5.
> # Looks like your test died before it could output anything.
> dubious
>         Test returned status 2 (wstat 512, 0x200)
> DIED. FAILED tests 1-5

> My perl version is:

> This is perl, version 5.005_03 built for i386-freebsd. I also installed
> the URI perl module that was needed.

> Any thoughts on what could be going on?

> I may just move on to SpamAssassin 3.0 with the 3.0 plugin and see if it
> clears up.

Hi Jason,
I'm pretty sure you will need a more recent version of Perl to
run this.  The other developers here will have a better idea,
but upgrading to the latest Perl may be needed.  (FWIW SA 3.0
probably also needs a fresher(est) Perl.)

Jeff C.
-- 
Jeff Chan
mailto:jeffc at surbl.org
http://www.surbl.org/



More information about the Discuss mailing list