[SURBL-Discuss] SURBL test

Cal Evans cal at calevans.com
Tue Apr 13 15:09:48 CEST 2004


Gentoo.
and SpamCopURI.pm is in
/usr/lib/perl5/site_perl/5.8.2/Mail/SpamAssassin

I moved the *.pm into
/usr/lib/perl5/vendor_perl/5.8.2/Mail/SpamAssassin

and now it works.  Thanks for prodding me. (that's what I get for doing 
this without an ebuild!)  :)

Let me know how I may be of service,
=C=
* Cal Evans
* http://www.eicc.com
* We take care of your IT,
* So you can take care of your business.
*
* I think inside the sphere.


Walker Aumann wrote:
> On Tue, 2004-04-13 at 11:42, Cal Evans wrote:
> 
>>That does solve the test problem but once I do make install and then 
>>spamassassin --lint I still get:
>>Failed to compile URI SpamAssassin tests, skipping:
>>         (syntax error at /usr/share/spamassassin/81_spamcop_uri.cf, 
>>rule SPAMCOP_URI_RBL, line 1, near "eval:"
>>syntax error at /usr/share/spamassassin/20_uri_tests.cf, rule 
>>URI_OFFERS, line 178, near ";
>>}"
>>)
>>Any idea what could be causing this?
> 
> 
> Are you running on a Debian system?
> 
> When I ran into this, it was because, on a Debian system, the .pm files
> were not installed in the library directory perl was using for the
> existing SpamAssassin installation.  They went into a SpamCopURI
> directory.  If you move them from the SpamCopURI directory to the
> SpamAssassin one, it should work fine.
> 


More information about the Discuss mailing list