[SURBL-Discuss] Make test error with Mail-SpamAssassin-SpamCopURI-0.12

Eric Kolve ekolve at comcast.net
Thu Apr 22 12:38:42 CEST 2004



Can you run: 

perl -MURI -e 'print $URI::VERSION,"\n"';


I think you may have an older version of URI.

If this is the case, I will add 1.30 to the PRE_REQPM.

--eric

On Thu, Apr 22, 2004 at 11:12:26AM -0700, RW Hawkins wrote:
> I am trying to get the SpamCopURI working with our Spamassassin setup. I 
> think this approach to spam smashing is very promising, great work! The 
> error I get is as follows:
> 
> [root at mail-in Mail-SpamAssassin-SpamCopURI-0.12]# perl Makefile.PL
> Checking if your kit is complete...
> Looks good
> Writing Makefile for Mail::SpamAssassin::SpamCopURI
> [root at mail-in Mail-SpamAssassin-SpamCopURI-0.12]# make
> mkdir blib
> mkdir blib/lib
> mkdir blib/lib/Mail
> mkdir blib/lib/Mail/SpamAssassin
> mkdir blib/arch
> mkdir blib/arch/auto
> mkdir blib/arch/auto/Mail
> mkdir blib/arch/auto/Mail/SpamAssassin
> mkdir blib/arch/auto/Mail/SpamAssassin/SpamCopURI
> mkdir blib/lib/auto
> mkdir blib/lib/auto/Mail
> mkdir blib/lib/auto/Mail/SpamAssassin
> mkdir blib/lib/auto/Mail/SpamAssassin/SpamCopURI
> mkdir blib/man3
> cp lib/Mail/SpamAssassin/PerMsgStatus.pm 
> blib/lib/Mail/SpamAssassin/PerMsgStatus.pm
> cp lib/Mail/SpamAssassin/SpamCopURI.pm 
> blib/lib/Mail/SpamAssassin/SpamCopURI.pm
> cp lib/Mail/SpamAssassin/Conf.pm blib/lib/Mail/SpamAssassin/Conf.pm
> Manifying blib/man3/Mail::SpamAssassin::PerMsgStatus.3
> Manifying blib/man3/Mail::SpamAssassin::SpamCopURI.3
> Manifying blib/man3/Mail::SpamAssassin::Conf.3
> [root at mail-in Mail-SpamAssassin-SpamCopURI-0.12]# make test
> PERL_DL_NONLAZY=1 /usr/local/bin/perl -Iblib/arch -Iblib/lib 
> -I/usr/lib/perl5/5.00503/i386-linux -I/usr/lib/perl5/5.00503 -e 'use 
> Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t
> t/blacklist.........syntax error at 
> blib/lib/Mail/SpamAssassin/SpamCopURI.pm line 107, near "$f :"
> BEGIN failed--compilation aborted at t/blacklist.t line 4.
> # No tests run!
> dubious
>        Test returned status 255 (wstat 65280, 0xff00)
> Undefined subroutine &Test::Harness::WCOREDUMP called at 
> /usr/lib/perl5/5.00503/Test/Harness.pm line 288.
> make: *** [test_dynamic] Error 255
> 
> From past user errors I am guessing I have something out of date, but 
> not sure exactly what.
> 
> Thanks in advance,
> RW
> 
> 
> _______________________________________________
> Discuss mailing list
> Discuss at lists.surbl.org
> http://lists.surbl.org/mailman/listinfo/discuss


More information about the Discuss mailing list