[SURBL-Discuss] Problems with uri/_foreign

Eric Kolve ekolve at comcast.net
Fri Apr 30 10:14:56 CEST 2004


What version of URI do you have?  I may need to bump the version
requirement up. 

You can find this out with:

perl -MURI -e 'print $URI::VERSION,"\n"'


--eric


On Fri, Apr 30, 2004 at 10:11:33AM -0500, Matt Yackley wrote:
> Hi all,
> 
> I'm hoping that someone can whack me with a clue-stick here.  I'm running
> into problems getting SURBL up and running.
> 
> System:
> RedHat 9
> SA 2.63
> Amavisd-new
> SpamCopURI 0.14
> 
> I downloaded and ran through the install of the SpamCopURI 0.14 package,
> put my rules in place, and restarted my services.
> 
> Here is the error that I receive, each time a messae passes through the
> system:
> Failed to run SPAMCOP_URI_RBL SpamAssassin test, skipping:
>         (Can't locate URI/_foreign.pm in @INC (@INC contains: lib
> /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
> /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
> /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
> /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
> /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at
> /usr/lib/perl5/site_perl/5.8.0/URI.pm line 56.
> )
> 
> 1. I re-copied the three .pm files from the source, like the install docs
> advised.
> 2. The _foreign.pm file does exist at
> /usr/lib/perl5/site_perl/5.8.0/uri/_foreign.pm
> 3. CPAN claims that URI is up to date
> 4. A quick google search and search of the SURBL archives don't seem to
> offer much info on this error
> 
> I'm sure that I'm missing something silly, so any pointers would be great.
> 
> Thanks,
> Matt
> 
> _______________________________________________
> Discuss mailing list
> Discuss at lists.surbl.org
> http://lists.surbl.org/mailman/listinfo/discuss


More information about the Discuss mailing list