[SURBL-Discuss] Problems installing SPAMCOP_URI - Make test e rror

Martin Lyberg martin.lyberg at idkommunikation.com
Thu May 27 15:52:28 CEST 2004


Hi!

I solved the problem by this thread:

http://lists.surbl.org/pipermail/discuss/2004-May/000522.html

But now i can't get through 'make test'. This gives me the following:

make test

---snip---

Failed 9/9 tests, 0.00% okay
t/whitelist........Can't locate URI/QueryParam.pm in @INC (@INC contains:
/root/Mail-SpamAssassin-SpamCopURI-0.16/blib/lib
/root/Mail-SpamAssassin-SpamCopURI-0.16/blib/arch
/usr/lib/perl5/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .) at
/root/Mail-SpamAssassin-SpamCopURI-0.16/blib/lib/Mail/SpamAssassin/SpamCopUR
I.pm line 5.
BEGIN failed--compilation aborted at
/root/Mail-SpamAssassin-SpamCopURI-0.16/blib/lib/Mail/SpamAssassin/SpamCopUR
I.pm line 5.
Compilation failed in require at t/whitelist.t line 6.
BEGIN failed--compilation aborted at t/whitelist.t line 6.
# Looks like your test died before it could output anything.
t/whitelist........dubious

        Test returned status 2 (wstat 512, 0x200)
DIED. FAILED tests 1-6
        Failed 6/6 tests, 0.00% okay
Failed Test       Stat Wstat Total Fail  Failed  List of Failed
----------------------------------------------------------------------------
---
t/blacklist.t        2   512     4    4 100.00%  1-4
t/dnsrbl.t           2   512     6    6 100.00%  1-6
t/extract_urls.t     2   512    15   15 100.00%  1-15
t/mailto.t           2   512     1    1 100.00%  1
t/open_redirect.t    2   512     5    5 100.00%  1-5
t/spamcopuri.t       2   512     9    9 100.00%  1-9
t/whitelist.t        2   512     6    6 100.00%  1-6
Failed 7/7 test scripts, 0.00% okay. 46/46 subtests failed, 0.00% okay.
make: *** [test_dynamic] Error 2

Any solution to this problem? Just before i did upgrade Net::DNS through
CPAN.

Thank you.

/ Martin



: -----Ursprungligt meddelande-----
: Från: Eric Kolve [mailto:ekolve at comcast.net] 
: Skickat: den 27 maj 2004 14:11
: Till: SURBL Discussion list
: Ämne: Re: [SURBL-Discuss] Problems installing SPAMCOP_URI
: 
: 
: On Thu, May 27, 2004 at 01:44:02PM +0200, Martin Lyberg wrote:
: > : Hi
: > :
: > : I've been reading alot about SURBL in SA-mailinglist, now 
: > : i've decided to give it a try. But im having trouble 
: > : installing SpamcopUri.
: > : 
: > : I have the following system: RH9, Postfix, SA 2.63
: > : 
: > : I get the following:
: > : 
: > : Perl Makefile.pl
: > : 
: > : Can't locate Mail/SpamAssassin.pm in @INC (@INC contains: 
: > : /usr/lib/perl5/5.8.0/i386-linux-thread-multi 
: > : /usr/lib/perl5/5.8.0 
: > : /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
: > : /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl 
: > : /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
: > : /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl 
: > : /usr/lib/perl5/5.8.0/i386-linux-thread-multi 
: > : /usr/lib/perl5/5.8.0 .) at Makefile.PL line 3. BEGIN 
: > : failed--compilation aborted at Makefile.PL line 3.
: > : 
: > : What is wrong here?
: 
: It looks like 'Perl' (was that really what was executed) 
: couldn't find Mail::SpamAssassin.  Do you know where it's 
: installed? This appears to be an issue with the @INC.
: 
: 
: --eric
: 
: 
: > 
: > Does anyone know a solution to this problem? Is there any easy 
: > solution?
: > 
: > Thanks in advance
: > 
: > / Martin
: > _______________________________________________
: > Discuss mailing list
: > Discuss at lists.surbl.org 
: > http://lists.surbl.org/mailman/listinfo/discuss
: _______________________________________________
: Discuss mailing list
: Discuss at lists.surbl.org 
: http://lists.surbl.org/mailman/listinfo/discuss
: 



More information about the Discuss mailing list